Discussion:
vi(m) not installed in minimum text-only pattern ?
(too old to reply)
Per Jessen
2014-10-14 08:09:58 UTC
Permalink
Raw Message
I've just done (yet another) minimum install and specifically checked to
see that vim was auto-selected for installation. Yet when I booted the
system, no vim was installed. Has anyone else seen this?
--
Per Jessen, Zürich (0.0°C)
http://www.hostsuisse.com/ - virtual servers, made in Switzerland.
--
To unsubscribe, e-mail: opensuse+***@opensuse.org
To contact the owner, e-mail: opensuse+***@opensuse.org
Per Jessen
2014-10-14 08:12:46 UTC
Permalink
Raw Message
Post by Per Jessen
I've just done (yet another) minimum install and specifically checked
to see that vim was auto-selected for installation. Yet when I booted
the system, no vim was installed. Has anyone else seen this?
Ah, found it - I had deselected 'libSM6' which is apparently required by
vim. It seems that vim requires libICE6, libSM6 and libXt6 which
AFAICT all have to do with X ??
--
Per Jessen, Zürich (0.0°C)
http://www.dns24.ch/ - free dynamic DNS, made in Switzerland.
--
To unsubscribe, e-mail: opensuse+***@opensuse.org
To contact the owner, e-mail: opensuse+***@opensuse.org
Andrei Borzenkov
2014-10-14 16:53:19 UTC
Permalink
Raw Message
В Tue, 14 Oct 2014 10:12:46 +0200
Post by Per Jessen
Post by Per Jessen
I've just done (yet another) minimum install and specifically checked
to see that vim was auto-selected for installation. Yet when I booted
the system, no vim was installed. Has anyone else seen this?
Ah, found it - I had deselected 'libSM6' which is apparently required by
vim. It seems that vim requires libICE6, libSM6 and libXt6 which
AFAICT all have to do with X ??
Given that

***@opensuse:~/src/yast/yast-storage> LC_ALL=C vim -g
E25: GUI cannot be used: Not enabled at compile time

that's really good question. Also Mandriva had vim-minimal which was
truly bare bone vi without any bells and whistles.

But I would love to know why text mode vim needs X11. Care to open a
bug report?
--
To unsubscribe, e-mail: opensuse+***@opensuse.org
To contact the owner, e-mail: opensuse+***@opensuse.org
Per Jessen
2014-10-15 06:47:22 UTC
Permalink
Raw Message
Post by Andrei Borzenkov
В Tue, 14 Oct 2014 10:12:46 +0200
Post by Per Jessen
Post by Per Jessen
I've just done (yet another) minimum install and specifically
checked to see that vim was auto-selected for installation. Yet
when I booted
the system, no vim was installed. Has anyone else seen this?
Ah, found it - I had deselected 'libSM6' which is apparently required by
vim. It seems that vim requires libICE6, libSM6 and libXt6 which
AFAICT all have to do with X ??
Given that
E25: GUI cannot be used: Not enabled at compile time
that's really good question. Also Mandriva had vim-minimal which was
truly bare bone vi without any bells and whistles.
But I would love to know why text mode vim needs X11. Care to open a
bug report?
Sure, see https://bugzilla.opensuse.org/show_bug.cgi?id=901230
--
Per Jessen, Zürich (0.0°C)
http://www.dns24.ch/ - free dynamic DNS, made in Switzerland.
--
To unsubscribe, e-mail: opensuse+***@opensuse.org
To contact the owner, e-mail: opensuse+***@opensuse.org
jdd
2014-10-14 09:16:19 UTC
Permalink
Raw Message
Post by Per Jessen
I've just done (yet another) minimum install and specifically checked to
see that vim was auto-selected for installation. Yet when I booted the
system, no vim was installed. Has anyone else seen this?
vim is a large application, usually we found "vi" (ie: busybox, tinyvi;..)

jdd
--
To unsubscribe, e-mail: opensuse+***@opensuse.org
To contact the owner, e-mail: opensuse+***@opensuse.org
Carlos E. R.
2014-10-14 11:34:35 UTC
Permalink
Raw Message
Post by jdd
Post by Per Jessen
I've just done (yet another) minimum install and specifically checked to
see that vim was auto-selected for installation. Yet when I booted the
system, no vim was installed. Has anyone else seen this?
vim is a large application, usually we found "vi" (ie: busybox, tinyvi;..)
I think that 'joe' is smaller, and is installed by default. It is in the
DVD small rescue image, last time I looked, but I haven't checked the
minimum pattern.
--
Cheers / Saludos,

Carlos E. R.
(from 13.1 x86_64 "Bottle" at Telcontar)
Loading...